The Chrysler Minivan Fan Club Forums banner

21 - 36 of 36 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #21
I did have an Issue the other day when it was -20 would not start with Auto Start i had to go out and manually start it, it was flooded.

Still my 2001 has had a lack of Power on the interstate going up hills, (will down shift every time with cruise on) compared to my 2002 and my old 1998 you could just fill the power going up hills with cruise on never down shifted
 

·
fix it if you can
Joined
·
4,884 Posts
I did have an Issue the other day when it was -20 would not start with Auto Start i had to go out and manually start it, it was flooded.

Still my 2001 has had a lack of Power on the interstate going up hills, (will down shift every time with cruise on) compared to my 2002 and my old 1998 you could just fill the power going up hills with cruise on never down shifted
If one or more of the injectors is/are leaky, it will bleed down the pressure in the rail as it sits (all you have to do is measure it before you shut it down for the night and before you start it in the morning) However, a faulty pressure regulator can do same.

ECU is in very accessible place on your '01, so if you have a scope you can probe the injector outputs to make sure they have a clean waveform and are not cross firing (it's not unheard of melted harnesses doing damage to PCM)
 

·
Registered
Joined
·
102 Posts
Discussion Starter #23
I Picked up a ECU today at the Junk Yard looks like it had a software update on 2010 mine does not have a sticker like that I will install it in the next week or so, already check the Fuel system pressure did not leak down as it sit
 

·
fix it if you can
Joined
·
4,884 Posts
Just make sure that ECU came from a non Immob equipped van BEFORE you plug it in. (ESP. if your van does not have Immob system - otherwise you could lock up yours)
 

·
Registered
Joined
·
102 Posts
Discussion Starter #25
What is a non Immob?, The van was a 2001 AWD it was like a dup van but different color going out later to get the front bumper cover
 

·
Registered
Joined
·
102 Posts
Discussion Starter #26
ok that could be a Problem that system was disabled when and after market Auto Start was installed
 

·
fix it if you can
Joined
·
4,884 Posts
What is a non Immob?, The van was a 2001 AWD it was like a dup van but different color going out later to get the front bumper cover
Immob my shorthand for Sentry Key Immobilizer System - transponder key & module that is used to authenticate ignition sequence.

I'd, at the very least, get the vin numbers for your and donor vans and pull build sheets from Chrysler corp site to see if either came with the system from the factory...
 

·
Registered
Joined
·
102 Posts
Discussion Starter #28
My Van does have the chip in the Key, If i install the ECM it won't work? and if it doesn't can i put the old ECM back in it will work again? I will get the Vin# from that van at the just Yard just in Case
 

·
fix it if you can
Joined
·
4,884 Posts
My Van does have the chip in the Key, If i install the ECM it won't work? and if it doesn't can i put the old ECM back in it will work again? I will get the Vin# from that van at the just Yard just in Case
Let me preface this by saying I know next to nothing about 1st gen Sentry systems on these vans. (my van has 2nd gen) Thus the following is my opinion and should not be taken as authoritative source.

Since your van has the system, you're not likely to disable ignition on it - it may not work with donor PCM but should revert to working if you put original module back in.
If donor does not have Immob, the donor PCM will 'learn' and lock to your Immob system - it should work just fine in your van (but will not work in any other, once it's locked).
However, if donor does have Immob, I'd say the chances of that PCM working (without re-programming) are 50/50 at best.

When you swap the PCM and start the van, if it shuts off after a few seconds - that is your clue that Immob is kicking in. (after a few attempts it will not start at all (lock out) and may even prevent starter engagement)
 

·
Registered
Joined
·
102 Posts
Discussion Starter #30
Update you were correct about the ECM i install it and it just died after a few Seconds so i remove it, call they said $200 to swap the ECM reprogram make a new key (i was told if i lock it, just put the chip key back in the van and let it sit for a couple hours they will reset after a couple hours)
NOW yesterday been working on wife's van went to U-Pull-it again got another ECM that's does not use the chip key it runs in her van i will put it in mine when the weather get better, if that don't work i will replace the fuel injectors
 

·
Registered
Joined
·
102 Posts
Discussion Starter #31
Update Well,van broke down did a bunch of work on it, Plugs, wires, Coil, Fuel injectors, EGR Valve, cleaned Trottle Body, with New IAC did this all Saturday today Engine Light Code P0172
 

·
Registered
Joined
·
980 Posts
Never mind, got to end of thread too late....
damaged fuel injector harness could have damaged a driver on the ECU / computer and the injector/s dont fire correctly now.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #33
that is possible light only comes on coasting to a stop when it wants to, i got a couple other ECU's at u-pull-it that does not have the Chip seen the keys in each van they both work in wife's van I installed one in mine it started and was running putting the van back together i shut it off and tried the Auto Start would not start and run, then when i tried to start with key again wouldn't start and run more than 3 seconds so i installed the Van's ecu back in now the heater don't work blows cold air out vents tried a reset on that didn't work

Any Ideas? I could buy a rebuilt ECU on-Line $168 reprogrammed to my van's VIN and codes what do you think?
 

·
Registered
Joined
·
102 Posts
Discussion Starter #34
I call them the Price goes up to $229
 

·
Registered
Joined
·
102 Posts
Discussion Starter #35
Been reading on the Computer system i think i under stand how it works now, BUT I'm confused on and if it even had the right ECU in The van called flagship1 gave them my Vin # he said it was a Part # should be 4727403AK and i told him it was 4727405AL does anyone know what the difference is? could be the reason that some things don't work in the van Like the Side doors won't work with the buttons
 

·
Registered
Joined
·
102 Posts
Discussion Starter #36
Well bought a New computer had them program it with my Vin# Work Perfect for 3 days engine light again p0172
 
21 - 36 of 36 Posts
Top