The Chrysler Minivan Fan Club Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
I have a 2005 T&C and the oil light has started to come on. The oil light comes on first time the car is started, but most times will go out if the car is restarted. There's plenty of oil. I did replace the oil pressure sensor about 3 years ago. So Is my oil pressure sensor bad again or oil pump this time?
 

·
Registered
Joined
·
90 Posts
I have a 2005 T&C and the oil light has started to come on. The oil light comes on first time the car is started, but most times will go out if the car is restarted. There's plenty of oil. I did replace the oil pressure sensor about 3 years ago. So Is my oil pressure sensor bad again or oil pump this time?
Have the pressure checked. Probably the sensor. Check for warranty

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
568 Posts
have you ever had the o-ring on the oil pickup replaced? usually the light is always just the sensor

if your bearings were that worn, you'd probably notice a lot more things than just the light
 

·
--UNKNOWN MEMBER--
Joined
·
9,739 Posts
have you ever had the o-ring on the oil pickup replaced? usually the light is always just the sensor

if your bearings were that worn, you'd probably notice a lot more things than just the light
If you have worn cam bearings, you will not notice anything else but oil light.

I never heard of a failed oil pick up O-ring on any engine, only on transmissions.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
I have have some of the gaskets replaced, but can't be sure if that was one of them.
 

·
Registered
Joined
·
568 Posts
I never heard of a failed oil pick up O-ring on any engine, only on transmissions.
i've heard the one on these 3.3/3.8 engines wears and then starts to leak oil after time, it's just something to replace any time the pan is dropped
 

·
Registered
Joined
·
509 Posts
It's not a matter of oil leaking... it's a matter of air being pulled in with or instead of the oil and causing the hydraulic valve lash adjusters to be compressible instead of non-compressible... which, in turn, causes increased valve noise. If it got bad enough, I suppose it could show up as low oil pressure as well but I've not ever seen it that bad.
 

·
Super Moderator
Joined
·
21,988 Posts
I have a 2005 T&C and the oil light has started to come on. The oil light comes on first time the car is started, but most times will go out if the car is restarted. There's plenty of oil. I did replace the oil pressure sensor about 3 years ago. So Is my oil pressure sensor bad again or oil pump this time?
I replaced the OE oil pressure sensor on the 2007 GC with one made by Standard Motor Products. That outlasted its 12 month warranty by one month. Replaced it with a Mopar which lasted much longer and is still working today.

So, it's more than likely that your 3 year old sensor is defective..
 

·
Registered
Joined
·
31 Posts
Discussion Starter #13
Ok, I replaced the oil pressure sensor and so far all is well. I'm just surprised it was that since it was replaced about three years ago. Thanks to all with your suggestions!
 
1 - 13 of 13 Posts
Top