The Chrysler Minivan Fan Club Forums banner

1 - 5 of 5 Posts

2 Posts
Discussion Starter #1
Hi All,

I've been a silent member for awhile now as I haven't had anything to contribute. Now I'd like to share my current experience with Mopar Tech Authority.

I leased a 2012 T&C and then a 2015 which I now own. (I might have leased a 2018 instead if there was such a thing).

So I decided even though it's expensive it would be worthwhile to have the factory service information and wiring diagrams. So I took the bitter pill and ordered the USB combo from Today I received one little credit-card-sized USB fold-out drive with the service information and another with the wiring diagrams.

Well, the service information USB drive doesn't even work! I tried it in two different Windows 7 PC's, and it just plain doesn't work. The wiring diagram USB works perfectly in both computers, so I know it's not my PC's.

So I called the 800 number on the card and spoke with a tech support rep. She was cordial enough, but the bottom line is, she put me on hold for 5 minutes only to come back and tell me that "since my order was over $60, the situation has to be escalated to the help desk. They'll get back with you in about 2 business days."

Are you kidding me? Is this the first time in history a USB drive has gone bad? You can't just send me another one plus a return label and I'll send the bad one back? Nope. I asked if she could at least give me a couple days worth of access to the information online until this gets resolved. Nope.

I understand they're probably terrified of people trying to scam extra copies of their shop manuals or whatever. But they can't send me, who bought one of their $36000 vehicles, another 15 cents (list price) worth of plastic and silicon without a grand jury hearing???

This stinks. At least when shop manuals were printed and bound, you had something. (And for the $16 they charged me for ground shipping, they could have sent paper manuals!) Now, even if they eventually send me a USB drive that works, I'll have to wonder if it's still going to work when I need it.

I also found out from the tech rep that there is NO WARRANTY on these things. Just FYI...

Super Moderator
22,812 Posts
Have you contacted Chrysler Cares?

2 Posts
Discussion Starter #4
Hey folks, I thought I'd let everyone who is interested know the outcome of this ordeal, which was only just rectified LAST WEEK (about 70 days after purchase).

My money (including shipping) was credited back to my account on 10/10 for the product I purchased on 7/30 and shipped back on 8/14.

Cliff's Notes:

I received the two-USB drive set on 8/1. The Wiring USB worked; the Service Information (Manual) USB did not work at all. I called TechAuthority that night and they told me I'd be contacted in a few days (see OP).

A couple days later I received an email with some instructions attached. These instructions assumed you could "open" the USB and see the files/folders. So, they were useless in this situation.

I went back and forth with TechAuthority for about the next two weeks, when they finally agreed to send a replacement set of USB's once I returned the ones I had. They were gracious enough to issue a UPS Call Tag so I didn't have to pay for return shipping and UPS came to my door to pick up the package on 8/14. (Hooray!)

So I gave them what I thought was a rather generous two weeks (I live under 20 miles from the return address) and still hadn't received any contact from TechAuthority or replacement USB's. So I contacted TechAuthority again on 8/26 to see what was up.

About one week later I received the response

"Unfortunately, we have discovered a technical issue with the product that will need to be corrected. Our apologies we don't have a time frame on when the product will be available again.
A full refund will be processed ."

(It took two weeks to convince them it wasn't "user error" and to accept the return, and, lo and behold, it turns out they're all defective!)

But, a week after that, still no credit back to my card. I inquired and received the following:

"A full refund was processed on 9.12.19 for your order. Please allow approximately 15 business days for this refund to post to your credit card account. "

Okay, fine. So I gave 'em 17 business days...still no refund. What gives??? (don't get me started about how it only took a few minutes for them to TAKE the money originally, but giving it back, hey, that could take weeks!)

Contacted TechAuthority again on 10/9. Response:
"Our apologies for the delay in the processing of your refund.
Unfortunately, the there was a processing error for the refund request on 9.12.19.
Our Account Team resubmitted the request on 10.9.19 and this refund should be reflected on your statement shortly.
Again, we apologize for the inconvenience this issue has caused you."

And finally, the original charge was credited back to my account on 10/10/2019. AT LAST!

So, I think I'm gonna buy me the hard-copy Chilton and hope for the best.

"Hallelujah! Holy sh1t! Where's the Tylenol???"
1 - 5 of 5 Posts