Rad fans keep running with engine off ?



ChryslerMiniVan.net is the premier Chrysler Minivan Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34

Thread: Rad fans keep running with engine off ?

  1. #1
    Join Date
    Apr 2008
    Posts
    338
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Rad fans keep running with engine off ?

    Hi shut the car off- hear the radiator fans running -they will not go off-i pulled the negative bat terminal off-so my battery does not drain -so have temporary control of the problem-please advise -as to the most likely cause-if experienced with same problem -thank you ===tony===

  2. Remove Advertisements
    Chrysler Minivan Forums
    Advertisements
     

  3. #2
    Join Date
    Apr 2008
    Posts
    338
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hi my van is a 1999 3.8 town and country 105,000 miles- radiator fans never stayed on before with the ignition off-running all the time -if battery is connected please advise !!

  4. #3
    Join Date
    Apr 2008
    Location
    New England, USA
    Posts
    1,659
    Thanks
    20
    Thanked 13 Times in 10 Posts


    So with the battery now disconnected, if you waited until the engine was cold, say overnight, and went and reconnected the battery, would the fan start right up?

    Could be a stuck fan relay.
    2009 Dodge Grand Caravan SXT (3.8L), Light Sandstone Metallic, 125K miles
    2005 Volvo XC70, 160K miles

    Previous van: 2002 Chrysler T&C, eX (3.8L)

  5. #4
    Join Date
    Apr 2008
    Posts
    338
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hi my van is a 1999 3.8 town and country lxi with 105,000--radiator fans keep running with the ignition turned off-never did this before-need good advise regarding this issue-please help thank you ===tony===

  6. #5
    Join Date
    Apr 2008
    Posts
    338
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hi will let you know the results in the morning-do you know were i would find the relay-would the bang on it method work if it is stuck-or does it get replaced ?

  7. #6
    Join Date
    Apr 2008
    Posts
    338
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hi if i connect the negative bat terminal now-while car is warm -the fans go right on and stay on thank you ===tony===

  8. #7
    Join Date
    Apr 2008
    Posts
    338
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hi van cooled down some- put the negative terminal back on -all is well- fans not on when the ignition is off-problem seams fixed-for the moment-will have to now keep an eye on this-and the battery wrench handy-i know these things do not heal themselves as a rule-we did have a lot of rain in fla from storm ---fay-will be watching-jump in if you have been here done this !!

  9. #8
    Join Date
    Apr 2008
    Location
    New England, USA
    Posts
    1,659
    Thanks
    20
    Thanked 13 Times in 10 Posts


    Do you have a temp gauge on your dash? Does it look like it's running higher than normal?

    I would not be too surprised if the fan was on for a while after the vehicle was shut down, especially if you ran it hard and/or it's hot out.

    Make sure your coolant level is OK.
    2009 Dodge Grand Caravan SXT (3.8L), Light Sandstone Metallic, 125K miles
    2005 Volvo XC70, 160K miles

    Previous van: 2002 Chrysler T&C, eX (3.8L)

  10. #9
    Join Date
    Dec 2006
    Location
    Tulsa, Oklahoma
    Posts
    220
    Thanks
    10
    Thanked 8 Times in 2 Posts


    I had this same problem on my 1996 T&C Touring. I shut the van off and the fan kept running. I disconnected the battery, hooked it back up, and the fan didn't run anymore. Unfortunately, the fan relay refused to close when I needed it to close. (at a traffic light) and the van started to overheat.

    As long as I was driving the van it would stay cool without the fan running.

    I replaced the fan relay, and all was well.
    De Hill

    2006 T&C Touring

    previous: 1996 T&C Touring

  11. #10
    Join Date
    Apr 2008
    Posts
    338
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Hi mine is doing exactly what yours did-seam to run hot when sitting still-were is the relay you replaced-and what was its cost ?thank you

+ Reply to Thread

Similar Threads

  1. '02 T&C: ONLY when engine running - there's NO pwr windows, HVAC, wipers & radio
    By RobReece in forum 4th. Generation Chrysler Minivans: 2001-2007
    Replies: 13
    Last Post: 01-06-2010, 03:05 PM
  2. radiator fans always running even when the engine is off
    By alain95i4 in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 2
    Last Post: 06-09-2009, 08:40 PM
  3. Check Engine Light when running A/C - Transmission problem
    By gfunk999 in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 20
    Last Post: 11-21-2008, 07:46 PM
  4. Rough running engine and Service Engine Soon Light
    By 97grandvoyagerse in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 8
    Last Post: 07-14-2008, 08:39 PM
  5. Radiator fans not running
    By sakis_cycles in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 7
    Last Post: 05-19-2005, 07:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts