2007 Town & Country Lights Flickering



ChryslerMiniVan.net is the premier Chrysler Minivan Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: 2007 Town & Country Lights Flickering

  1. #1
    Join Date
    Apr 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts


    2007 Town & Country Lights Flickering

    Hi new to the post. I have a 2007 Chrysler Town & Country Limited 7000 miles and have a problem with lights flickering Chrysler bought back my 06 for this problem at 3000 miles. Dash, headlights, dome, & tail lights all flicker. I took in 2nd time now and the filed rep from chrysler looked at it and demed it undriveable but they let me pick it up. They told me both times to stop useing my heated seats. I have been pulled over once for it because the cop thought that i was flashing my lights at him, its that bad. I was wondering if anyone esle has had this problem and what they did about
    Thanks
    Paul

  2. Remove Advertisements
    Chrysler Minivan Forums
    Advertisements
     

  3. #2
    Join Date
    Jan 2005
    Location
    Fayetteville, NC
    Posts
    9,436
    Country: Users Country Flag
    Thanks
    10
    Thanked 66 Times in 50 Posts


    If a representative from Chrysler deemed it undriveable, bring it back to the dealership, park it, and insist on a loaner car until they fix it. If their recommendation (Chrysler's) is that you can't drive the car, they've backed themselves into fixing it. I would get insistent with them.

    And welcome to the forum!
    '11 Toyota Camry | 2.5/6AT | Sandy Beach
    '07 Chrysler T&C | 3.8/4AT | Cognac Crystal
    '05 Acura MDX | 3.5/5AT | Billet Silver
    '97 Dodge Dakota | 5.2/4AT | Emerald Green

  4. #3
    Join Date
    Apr 2008
    Location
    Minnesota
    Posts
    6
    Thanks
    0
    Thanked 1 Time in 1 Post


    Hi, I'm also new here, and had a similar problem although from your description probably not as bad. All lights flickered, it was most noticeable in the headlights, overhead lights, and gear indicator. Very annoying. I have an 05 Dodge SE+.

    Turned out the battery ground cable was corroded. After cleaning it up no problems. I have a hard time believing a dealer couldn't find or diagnose a bad ground, but I've heard of worse.

  5. The Following User Says Thank You to plmn For This Useful Post:

    Isael (11-19-2014)

  6. #4
    Join Date
    Apr 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts


    They replaced the battery the last time I had it in and it still does the samething. The flickering is as bad as a strobe light. This is pretty horrible for a almost $40,000 van and they tell you to stop using the heated seats. The last time I checked that was one of the reason that I bought the van.

  7. #5
    Join Date
    Jun 2005
    Location
    KS
    Posts
    1,290
    Thanks
    2
    Thanked 1 Time in 1 Post


    It's been my experience that some minor flickering is indeed normal. However, if it's bad enough for a police action then a decent tech should be able to find the voltage drop.

    My 2 cents,

  8. #6
    Join Date
    Feb 2008
    Location
    Bedford,VA
    Posts
    29
    Thanks
    0
    Thanked 0 Times in 0 Posts


    The ground cable where it attaches to the frame must have a bad connection.

  9. #7
    Join Date
    Oct 2007
    Location
    Petawawa, Ontario
    Posts
    312
    Thanks
    0
    Thanked 0 Times in 0 Posts


    I get the flicker, but its nowhere as bad as this. Mine is barely noticeable and happens when the A/C compressor kicks in. Which in my eye seems normal.

    Ill echo the others here.. Start yippin at them.
    HyperFox
    Proud to serve my country! Support your Canadian Troops!
    2007 Dodge Grand Caravan Stow-N-Go
    Visit my blog: http://hyperfox2007.blogspot.com/

  10. #8
    Join Date
    Apr 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts


    They checked all grounds

  11. #9
    Join Date
    Dec 2008
    Posts
    1,985
    Thanks
    0
    Thanked 2 Times in 2 Posts


    Sounds like a control module connection.

  12. #10
    Join Date
    Apr 2007
    Location
    Southwest
    Posts
    4,479
    Country: Users Country Flag
    Thanks
    100
    Thanked 359 Times in 306 Posts


    I've read of corrosion at the Front Control Module (FCM) connection to the Inteligent Power Module (IPM) (fuse box next to battery) causing lights problems. The FCM is on the front of the IPM. Might check there.
    ******** We took the time to answer your post. Please give us some time and post the fix. You'll help hundreds. ********

    **** Follow all prescribed safety procedures before attempting any repairs. If in doubt, refer to a maintenance manual. ****

    96 Gr Caravan LE 3.8, 208K miles
    07 Fusion / 06 RAV 4 / 06 Accord / 94 Camry

+ Reply to Thread

Quick Reply Quick Reply

Similar Threads

  1. No Heat 2007 Town & Country
    By fsdmark in forum 4th. Generation Chrysler Minivans: 2001-2007
    Replies: 96
    Last Post: 11-01-2014, 10:41 PM
  2. 2007 town and country dies after startup???
    By triathloner in forum 4th. Generation Chrysler Minivans: 2001-2007
    Replies: 18
    Last Post: 11-20-2010, 10:43 PM
  3. 2007 Town and country 3.8 gas mileage
    By triathloner in forum 4th. Generation Chrysler Minivans: 2001-2007
    Replies: 14
    Last Post: 03-06-2009, 02:40 AM
  4. 2007 Town and Country Review
    By DSMLVR in forum 4th. Generation Chrysler Minivans: 2001-2007
    Replies: 7
    Last Post: 03-06-2007, 04:12 PM
  5. 2007 Dodge Caravan/Town & Country Info
    By vanjeff in forum The Fireplace
    Replies: 0
    Last Post: 09-26-2006, 01:06 PM

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts