Caravan 3.3 not running right, misfire/rough idle...HELP!!



ChryslerMiniVan.net is the premier Chrysler Minivan Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6

Thread: Caravan 3.3 not running right, misfire/rough idle...HELP!!

  1. #1
    Join Date
    May 2011
    Posts
    4
    Country: Users Country Flag
    Thanks
    0
    Thanked 0 Times in 0 Posts


    Caravan 3.3 not running right, misfire/rough idle...HELP!!

    My 02 3.3 Caravan has developed a misfire (code says that it's the 2nd cylinder). It's lower mileage, always maintained, doesn't smoke, burn oil or anything like that.

    I've done the following. Preformed a injector cleaning surface ($150+), changed plugs, changed wires, checked injectors w/stethoscope for "ticking"...all seem to be working, as I can hear them. It seems any advice I get is bad advice. There are no garages anywhere near me (the small shops in the next town are not trustworthy), and Im tight on funds. Some ppl say "I think your motor is bad" (which if this was the case, it would smoke), while others say it's likely something simple. I want to fix this one myself, but don't really have tons of money to chase problems. The code it gave me was 2nd cyl misfire

    Any help would be appreciated. To show my gratitude, I would be willing to give the one who diagnoses it correctly a reward.

  2. Remove Advertisements
    Chrysler Minivan Forums
    Advertisements
     

  3. #2
    Join Date
    Dec 2009
    Location
    MA
    Posts
    252
    Thanks
    5
    Thanked 18 Times in 15 Posts


    Before I threw any more money at it, I'd swap the #2 injector with one of the other injectors, clear codes, then see if the code jumps cylinders.

    2011 Grand Caravan, 3.6, 116k miles
    2005 Grand Caravan SXT, 3.8 247k miles, Sold
    2002 Grand Caravan SE, 3.3, 166k miles, Sold

  4. #3
    Join Date
    May 2011
    Posts
    4
    Country: Users Country Flag
    Thanks
    0
    Thanked 0 Times in 0 Posts


    I took the #2 plug out, and it's wet. I saw spark in the wire....but the plug is still wet. Is it possible the spark isn't strong enough?? Maybe a bad coil.

  5. #4
    Join Date
    Dec 2009
    Location
    MA
    Posts
    252
    Thanks
    5
    Thanked 18 Times in 15 Posts


    It's not likely a bad coil. Each segment of the coil fires two of the cylinders. So if it were failing you'd see a misfire on more than one cylinder. I suspect you may have an injector that is not closing entirely, allowing fuel to spray/ leak excessively and flood the cylinder. How does the van run? Do you smell gas at start up? does it sometimes stumble and seem to hiccup at first start? I recently had a bad injector on my van and those were the symptoms it would exhibit,although it did seem to run & idle, along with a misfire code on one cylinder. I pulled the intake and could tell that not one, but two of the ports were "washed" from bad injectors.

    2011 Grand Caravan, 3.6, 116k miles
    2005 Grand Caravan SXT, 3.8 247k miles, Sold
    2002 Grand Caravan SE, 3.3, 166k miles, Sold

  6. #5
    Join Date
    May 2011
    Posts
    4
    Country: Users Country Flag
    Thanks
    0
    Thanked 0 Times in 0 Posts


    thank you so much for the reply. No smoke comes out the tailpipe at all, and I really don't smell any strong odor of fuel. Sometimes the first 3 or 4 seconds after start up are especially rough, depending on how long it has sat without being started, but then it idles steadily with a consistent "pah pah pah pah pah". With that said, it always turns right over, and doesn't really seem like a car that's being flooded. It holds steady RPM at idle, doesn't stall even when driven, but you can tell it's not firing on all 6. It first seemed to me like it wasn't getting fuel to that cylinder, but the wet plug showed me that perhaps wasn't the case.

    I haven't pull the injectors yet....it looks like taking the plenum off is a big job (and I think there's a plenum gasket that needs to be replaced??)
    Last edited by John's van; 05-31-2011 at 10:19 AM.

  7. #6
    Join Date
    May 2011
    Posts
    4
    Country: Users Country Flag
    Thanks
    0
    Thanked 0 Times in 0 Posts


    P300, P302 are the codes

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts