Oil light on, Oil light off



ChryslerMiniVan.net is the premier Chrysler Minivan Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7

Thread: Oil light on, Oil light off

  1. #1
    Join Date
    Jan 2004
    Location
    DC area
    Posts
    309
    Thanks
    5
    Thanked 6 Times in 3 Posts


    Oil light on, Oil light off

    What's it mean when you start the van (cold) and the oil light comes on, but when you shut the engine off then turn it back on, the light goes out and stays out. It will stay on even after it warms up, but always goes out if you turn engine off and then on.
    --
    Scott
    2005 Dodge Grand Caravan SXT
    3.8L-V6, 155K miles.

    Previously had:

    *1999 Plymouth Grand Voyager SE 3.3L-V6 FFV, 141K miles.
    *1999 Braun Entervan III (Dodge Grand Caravan modified for wheelchair users) - 65k miles 3.3L V6 FFV
    *1988 Plymouth Grand Voyager SE 3.0 V6 with 3 spd tranny -168K miles on it.

  2. Remove Advertisements
    Chrysler Minivan Forums
    Advertisements
     

  3. #2
    Join Date
    Jul 2008
    Location
    Niles Il.
    Posts
    10,098
    Country: Users Country Flag
    Thanks
    57
    Thanked 495 Times in 457 Posts


    Well, if your engine hasn't failed from lack of lubrication, I would say your pressure sending unit is bad. Fairly common failure too.
    Candy the van. '98 Sport 3.8L 132,200 miles. Used trans at ~96k. Great piece of my life and a fine van.

    '69 GTO drop top
    www.facebook.com/people/Andy-Greif/1410438927

  4. #3
    Join Date
    Jun 2009
    Location
    Jefferson City, TN
    Posts
    3,051
    Country: Users Country Flag
    Thanks
    356
    Thanked 253 Times in 204 Posts


    If the engine knocks or makes any sounds, you may have an engine issue.

    However I'd be willing to bet the engine is quiet all the time. Seeing how that is most likely the case, I'd say the oil pressure sending unit is going bad. Put a new one in it. Also if you live around squirrels, I'd check the wiring for the sending unit also.
    Jeff
    http://www.facebook.com/eddie.munster
    Current:
    2007 Grand Caravan/3.8L V6/103K mi/original 41TE
    2006 300C/5.7L HEMI V8/128/K mi/original W5A580
    2002 PT Cruiser/2.4L I4/139K mi/original 40TE
    1992 S-10/4.3L V6/249K mi/original 4L60E
    Previous minivans:
    1997 Grand Voyager SE/traded@192K mi/3.3L V6/original 41TE
    2003 Grand Caravan Sport/3.8L V6/traded@124K mi/original 41TE
    2007 T&C/3.8L V6/traded@44K mi/ original 41TE
    2010 T&C Touring/3.8L V6/the ex's@72K mi/original 62TE

  5. #4
    Join Date
    Apr 2009
    Location
    Empire State
    Posts
    3,200
    Country: Users Country Flag
    Thanks
    202
    Thanked 278 Times in 245 Posts


    any chance this started soon after an (engine) oil & filter change? (if so what brand filter?)
    relevant vehicle: '05 -=C=- T&C Ltd @~110K

  6. #5
    Join Date
    Oct 2003
    Location
    Niagara Ontario
    Posts
    754
    Country: Users Country Flag
    Thanks
    23
    Thanked 73 Times in 54 Posts


    I had this problem on my van, It also set a code that did not display the check engine light. I simply replaced the Oil pressure sensor and the problem is gone for good.
    Hank
    07 Dodge Caravan SXT 3.3L Gold 105,000 kms
    05 Dodge Caravan SE 3.3L Silver 165,000 kms

  7. #6
    Join Date
    Oct 2008
    Posts
    1,000
    Thanks
    2
    Thanked 57 Times in 54 Posts


    Like was said, replace the sender.

    Or attach a mechanical oil pressure tester.

  8. #7
    Join Date
    Jan 2004
    Location
    DC area
    Posts
    309
    Thanks
    5
    Thanked 6 Times in 3 Posts


    Thanks much! It was not right after an oil change, but not long after one. Maybe a week.
    --
    Scott
    2005 Dodge Grand Caravan SXT
    3.8L-V6, 155K miles.

    Previously had:

    *1999 Plymouth Grand Voyager SE 3.3L-V6 FFV, 141K miles.
    *1999 Braun Entervan III (Dodge Grand Caravan modified for wheelchair users) - 65k miles 3.3L V6 FFV
    *1988 Plymouth Grand Voyager SE 3.0 V6 with 3 spd tranny -168K miles on it.

+ Reply to Thread

Similar Threads

  1. ABS light, Fuel Light + nonworking gauge after Maaco painted van. Any ideas?
    By mishagos in forum 2nd Generation Chrysler Minivans: 1991-1995
    Replies: 4
    Last Post: 05-11-2011, 09:26 PM
  2. Brake warning light,on intermittenly,not abs light
    By oldman in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 5
    Last Post: 12-23-2010, 10:23 PM
  3. ABS Light, Air Bag Light , No cluster gauges
    By seaspice in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 3
    Last Post: 10-07-2009, 02:16 AM
  4. Radio shorted out then Battery Light & ABS light came on. WHY??
    By ilovemyscents in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 27
    Last Post: 07-25-2009, 01:07 AM
  5. Oil Light
    By hope in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 7
    Last Post: 05-31-2006, 01:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts