Can I clean the MAP sensor?



ChryslerMiniVan.net is the premier Chrysler Minivan Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: Can I clean the MAP sensor?

  1. #1
    Join Date
    Jul 2008
    Location
    Virginia
    Posts
    155
    Thanks
    2
    Thanked 0 Times in 0 Posts


    Can I clean the MAP sensor?

    Just pulled my MAP sensor, and it has dirt, sand and oily residue on it. Can I clean it up and pop it back in? If so what can I clean it with?
    96 Town and Country LXi w/ 3.8
    2000 Saturn SL1

  2. Remove Advertisements
    Chrysler Minivan Forums
    Advertisements
     

  3. #2
    Join Date
    Jun 2009
    Location
    Jefferson City, TN
    Posts
    3,051
    Country: Users Country Flag
    Thanks
    356
    Thanked 253 Times in 204 Posts


    If you just want to clean it, use contact cleaner. If it is malfuctioning, cleaning it will not repair your issue.
    Jeff
    http://www.facebook.com/eddie.munster
    Current:
    2007 Grand Caravan/3.8L V6/103K mi/original 41TE
    2006 300C/5.7L HEMI V8/128/K mi/original W5A580
    2002 PT Cruiser/2.4L I4/139K mi/original 40TE
    1992 S-10/4.3L V6/249K mi/original 4L60E
    Previous minivans:
    1997 Grand Voyager SE/traded@192K mi/3.3L V6/original 41TE
    2003 Grand Caravan Sport/3.8L V6/traded@124K mi/original 41TE
    2007 T&C/3.8L V6/traded@44K mi/ original 41TE
    2010 T&C Touring/3.8L V6/the ex's@72K mi/original 62TE

  4. #3
    Join Date
    Apr 2007
    Location
    Southwest
    Posts
    4,305
    Country: Users Country Flag
    Thanks
    97
    Thanked 334 Times in 285 Posts


    Quote Originally Posted by jgbat View Post
    If you just want to clean it, use contact cleaner. If it is malfuctioning, cleaning it will not repair your issue.
    Blanket statements will bite sometimes. Yes, cleaning is going against the odds but I have read of it being a solid fix.
    ******** We took the time to answer your post. Please give us some time and post the fix. You'll help hundreds. ********

    **** Follow all prescribed safety procedures before attempting any repairs. If in doubt, refer to a maintenance manual. ****

    96 Gr Caravan LE 3.8, 208K miles
    07 Fusion / 06 RAV 4 / 06 Accord / 94 Camry

  5. #4
    Join Date
    Jul 2008
    Location
    Virginia
    Posts
    155
    Thanks
    2
    Thanked 0 Times in 0 Posts


    Quote Originally Posted by RIP View Post
    Blanket statements will bite sometimes. Yes, cleaning is going against the odds but I have read of it being a solid fix.
    Well this one was so gunked up I couldn't imagine it working right.
    96 Town and Country LXi w/ 3.8
    2000 Saturn SL1

  6. #5
    Join Date
    Oct 2008
    Location
    Now, LA - Lower Alabama (SE corner)
    Posts
    2,435
    Thanks
    36
    Thanked 63 Times in 55 Posts


    My Haynes manual warns against getting cleaners on the sensors around the throttle body while cleaning it or you may ruin them. I don't know if there is a way to clean them or with what, without damaging them, but someone who has done it hear with success may tell you exactly what part to clean and with what.
    2005 T&C Ltd 3.8 69k
    2000 Caravan 2.4l
    1990 Grand Caravan 3.3 149,000 owned 15yrs 4 trannies
    1990 Dynasty 3.0 120k 1 tranny 4yrs
    1981 Dodge Aries 2.6 only new car I ever bought 225k orig 11yrs
    1966 Dodge Coronet 440 Wagon, way old 1 yr. 135$ (Had to borrow it at the bank!)
    1964 Simca 1000 (bought for $10 rebored) 50k 4yrs
    1965 Ply Valiant V8 85k
    1964 Ply Valiant Wagon slant 6 200k 1 qt/200 miles
    1969 Corvair convertible 4 carb

  7. #6
    Join Date
    Jun 2009
    Location
    Jefferson City, TN
    Posts
    3,051
    Country: Users Country Flag
    Thanks
    356
    Thanked 253 Times in 204 Posts


    If cleaning it repaired the issue, the sensor wasn't getting proper electrical connection. I do not see how cleaning an electronic sensor, when the sensor is bad, will repair any issue.
    Jeff
    http://www.facebook.com/eddie.munster
    Current:
    2007 Grand Caravan/3.8L V6/103K mi/original 41TE
    2006 300C/5.7L HEMI V8/128/K mi/original W5A580
    2002 PT Cruiser/2.4L I4/139K mi/original 40TE
    1992 S-10/4.3L V6/249K mi/original 4L60E
    Previous minivans:
    1997 Grand Voyager SE/traded@192K mi/3.3L V6/original 41TE
    2003 Grand Caravan Sport/3.8L V6/traded@124K mi/original 41TE
    2007 T&C/3.8L V6/traded@44K mi/ original 41TE
    2010 T&C Touring/3.8L V6/the ex's@72K mi/original 62TE

  8. #7
    Join Date
    Sep 2009
    Location
    South Dakota
    Posts
    110
    Thanks
    3
    Thanked 0 Times in 0 Posts


    new maps under $30.00 at rockauto

  9. #8
    Join Date
    Jun 2009
    Location
    Jefferson City, TN
    Posts
    3,051
    Country: Users Country Flag
    Thanks
    356
    Thanked 253 Times in 204 Posts


    Exactly my point. If it is malfunctioning, replace it. It is not like they are expensive.
    Jeff
    http://www.facebook.com/eddie.munster
    Current:
    2007 Grand Caravan/3.8L V6/103K mi/original 41TE
    2006 300C/5.7L HEMI V8/128/K mi/original W5A580
    2002 PT Cruiser/2.4L I4/139K mi/original 40TE
    1992 S-10/4.3L V6/249K mi/original 4L60E
    Previous minivans:
    1997 Grand Voyager SE/traded@192K mi/3.3L V6/original 41TE
    2003 Grand Caravan Sport/3.8L V6/traded@124K mi/original 41TE
    2007 T&C/3.8L V6/traded@44K mi/ original 41TE
    2010 T&C Touring/3.8L V6/the ex's@72K mi/original 62TE

  10. #9
    Join Date
    Jul 2008
    Location
    Niles Il.
    Posts
    10,106
    Country: Users Country Flag
    Thanks
    57
    Thanked 495 Times in 457 Posts


    Mine was near $70 when i replaced it in January. I couldn't wait for shipping as I need my van to commute to/from school and it randomly dieing every few minutes was not good.
    Candy the van. '98 Sport 3.8L 132,200 miles. Used trans at ~96k. Great piece of my life and a fine van.

    '69 GTO drop top
    www.facebook.com/people/Andy-Greif/1410438927

  11. #10
    Join Date
    Jul 2008
    Location
    Virginia
    Posts
    155
    Thanks
    2
    Thanked 0 Times in 0 Posts


    Well I cleaned mine, reinstalled it, and it started and ran fine. We'll see how it runs after I get the radiator put in.
    96 Town and Country LXi w/ 3.8
    2000 Saturn SL1

+ Reply to Thread

Similar Threads

  1. Dim Headlights - How To Clean?
    By MAD King in forum 3rd Generation Chrysler Minivans: 1996-2000
    Replies: 11
    Last Post: 02-20-2012, 04:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts