First Post and need help with 2011 wiper issue



ChryslerMiniVan.net is the premier Chrysler Minivan Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22

Thread: First Post and need help with 2011 wiper issue

  1. #1
    Join Date
    Dec 2016
    Posts
    10


    First Post and need help with 2011 wiper issue

    Happy New Year all,

    I have been lurking a bit and thought it best I make my presence official and ask for help on a problem I am having.

    We have a 2011 GC Crew and it has been a gem (other than brakes)

    A month ago my wife was driving and the wipers started to operate very slowly on all three settings and woudl periodically stop mid swipe and then restart after a few moments again.

    I took it to the dealer and they said wiper motor so $378 later I was out the door and had absolutely the same issue, I'm surprised that they didn't QC the repair to see if it worked.
    We returned the van to the same dealer and he patiently explained the motor was not functioning because they "tested it" so the $378 stands, as well they said the issue was with the TIPM "likely caused by the bad wiper motor" so $1400 later out the door with a fresh TIPM and guess what...... still no change. It does exactly the same thing and I am now nearly $1800 out of pocket and more than furious.

    Can anyone steer me in the right direction for what is the likely cause of my issue so I can go in to a more competent dealer armed with a likely reason for the issue?

    Thanks everyone!

  2. Remove Advertisements
    Chrysler Minivan Forums
    Advertisements

  3. #2
    Join Date
    Jan 2015
    Location
    TEXAS, USA
    Posts
    4,073


    Welcome to the forum.

    See if ChryslerCares can help you get your money back and steer you to a different dealer.

    ChryslerCares is a Chrysler rep. and is a member of this forum.

    You can send him/her a P.M. here:

    ChryslerCares PM

    Mean time, post dealer's name for others to stay away from them.







    2012 Town & Country
    2006 Dodge Grand Caravan. 317,000 + Miles. -SOLD-
    Current Minivans I own.
    LEVY --UNKNOWN MEMBER--

  4. #3
    Join Date
    Dec 2016
    Posts
    10


    I talked to them again and they say to bring it in but they are "running out of ideas" WTH?? I called another dealer and explained what happened, they said really there are three things it could be, the wiper motor, TIPM and the multi function stalk.

    Could it be anything else?

  5. Remove Advertisements
    Chrysler Minivan Forums
    Advertisements

  6. #4
    Join Date
    Jan 2015
    Location
    TEXAS, USA
    Posts
    4,073


    It could be something as simple as a loose corroded wire/terminal.

    First, contact ChryslerCares so he/she can help you make an appointment with your dealer and to "get your money back"

    Running out of ideas doesn't sound very professional and will help you get your money back.







    2012 Town & Country
    2006 Dodge Grand Caravan. 317,000 + Miles. -SOLD-
    Current Minivans I own.
    LEVY --UNKNOWN MEMBER--

  7. The Following User Says Thank You to LEVY For This Useful Post:

    UN4GTBL(01-03-2017)

  8. #5
    Join Date
    Dec 2016
    Posts
    10


    Quote Originally Posted by LEVY View Post
    It could be something as simple as a loose corroded wire/terminal.

    First, contact ChryslerCares so he/she can help you make an appointment with your dealer and to "get your money back"

    Running out of ideas doesn't sound very professional and will help you get your money back.
    Will do, thanks!!

  9. #6
    Join Date
    Jan 2016
    Location
    Leamington, ON Canada
    Posts
    180


    daddy, where are you located in Canada?
    2016 Deep Cherry Dodge Grand Caravan CVP (with an aftermarket RT badge on the liftgate )

    Fully loaded .... power steering and power brakes.

  10. #7
    Join Date
    Dec 2016
    Posts
    10


    Quote Originally Posted by 2granddaughters View Post
    daddy, where are you located in Canada?
    London, just down the 401 from you....

  11. #8
    Join Date
    Mar 2014
    Location
    Minneapolis, MN.
    Posts
    95


    I agree, demand a refund. $1800 spent for a wiper malfunction???
    Shame on them.
    Please keep us posted.

    Quote Originally Posted by daddy2000gt View Post
    Happy New Year all,

    I have been lurking a bit and thought it best I make my presence official and ask for help on a problem I am having.

    We have a 2011 GC Crew and it has been a gem (other than brakes)

    A month ago my wife was driving and the wipers started to operate very slowly on all three settings and woudl periodically stop mid swipe and then restart after a few moments again.

    I took it to the dealer and they said wiper motor so $378 later I was out the door and had absolutely the same issue, I'm surprised that they didn't QC the repair to see if it worked.
    We returned the van to the same dealer and he patiently explained the motor was not functioning because they "tested it" so the $378 stands, as well they said the issue was with the TIPM "likely caused by the bad wiper motor" so $1400 later out the door with a fresh TIPM and guess what...... still no change. It does exactly the same thing and I am now nearly $1800 out of pocket and more than furious.

    Can anyone steer me in the right direction for what is the likely cause of my issue so I can go in to a more competent dealer armed with a likely reason for the issue?

    Thanks everyone!
    2012 Dodge Grand Caravan 3.6 SE (81,xxx miles)
    2000 Honda Odyssey Ex (209,xxx miles) - Traded

  12. The Following User Says Thank You to jasper60103 For This Useful Post:

    UN4GTBL(01-03-2017)

  13. #9
    Join Date
    Apr 2007
    Location
    SoCal
    Posts
    5,328


    Oh ChryslerCares where are you?

    Yet another box changer dealership. If it's not a box they don't have a clue.
    Last edited by RIP; 01-01-2017 at 01:00 PM.
    ******** We took the time to answer your post. Please give us some time and post the fix. You'll help hundreds. ********

    **** Follow all prescribed safety procedures before attempting any repairs. If in doubt, refer to a maintenance manual. ****

    96 Gr Caravan LE 3.8, 214K miles
    07 Fusion / 06 RAV 4 / 06 Accord

  14. The Following User Says Thank You to RIP For This Useful Post:

    UN4GTBL(01-03-2017)

  15. #10
    Join Date
    Dec 2016
    Posts
    10


    Well, I thought with a day off for new year's I would apply a bit of logic to the situation.

    I took the wiper cowl off and watched the wipers work for a bit then stop and then start again. I took the plug off the wiper motor and measured the voltage output across the various pins and found everything to be correct and working so that eliminated the TIPM and the Multifunction switch. I took the wiper arms off and it still would stop which eliminated the drag on the windshield. I unhooked the linkage and the motor didnt stop any longer. Voila!!! must be the linkage. I took the linkage off and checked and one of the pivots was seized. I pulled the pin out and cleaned and greased the pin and put in all back together and I am back in business.

    All in about 2 hours of my time and $0.25 worth of grease and a bucket of common sense.

    Stealerships suck... and Chrysler techs don't know their arse from a hole in the ground.

  16. The Following 2 Users Say Thank You to daddy2000gt For This Useful Post:

    georgef(01-02-2017), UN4GTBL(01-03-2017)

+ Reply to Thread

Quick Reply Quick Reply

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts